Your Truck Source

Your Truck Source


 
RULES  HomeHome  PortalPortal  CalendarCalendar  FAQFAQ  RegisterRegister  Log inLog in  
Have you told all your friends about the excitement here at MyTruckSource.com?
Have a new ride you want to show off? Or you want to see our other members rides? Check out our PRIDE & JOY Forum!

Share | 
 

 Long time and no picture post!

View previous topic View next topic Go down 
Go to page : Previous  1, 2
AuthorMessage
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   March 10th 2012, 9:31 pm

Got the rest of the chrome off today. Took a couple of cell phone pics, but will take some better ones tomorrow which will be when I post. Ordering up some fender flares this week to help dress it up now that there isn't any chrome, and I think I may wait until next weekend to install the body lift as I had to work today so I have a lot to do tomorrow. Don't worry, I will still post pictures tomorrow at some point!
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   March 11th 2012, 7:48 pm

Well, I only took two pictures, so here's the one that was worth a darn, lol. I don't know why, but I am grumpy as hell today and lazy too.



Next weekend I'll be doing a different sort of project. I'll start a separate thread for that when I get started with pictures.
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   March 12th 2012, 4:15 am

Haha I was grumpy and lazy too..... I'm blamin the stupid time change lol. I like it a lot better without the chrome, looks much cleaner.
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   June 17th 2012, 11:10 am

So in the last few months, I have made some changes to old Betty White (as me and some co-workers have started calling her Very Happy). Here's a couple of pics:

Minor wheeling:


Installed giant boob cannon:


Gear in bed:


CB install:




Glamour pic:


Topper back on:


Body lift install (1.5"):






And finished with another glamour shot by dads stock 2000:




Some more minor wheeling:



Cleaned up all the wiring bull crap in the cab:



Wired up my OHC:


More wheeling:



Road trip to Maple Falls, WA:




And back home:


Installed fender flares and a couple of stuck pics:





And took off the topper for a while so I can haul stuff for my old boss:


Back to top Go down
007jimmy
Moderator
Moderator
avatar

Posts : 1955

Age : 33
Location : levittown, PA

PostSubject: Re: Long time and no picture post!   June 20th 2012, 5:16 pm

Shes lookin preddy.. everytime i see this truck it makes me want one. only not in white because it would never look as good as yours.. lol
Back to top Go down
In2Trux
Moderator
Moderator
avatar

Posts : 1381

Age : 55
Location : North Bay Ont, Canada

PostSubject: Re: Long time and no picture post!   June 22nd 2012, 8:49 am

Awesome pictures.
Any body damage when you got stuck ???
I REALLY like the look with the topper gone

================================================
Glenn
*****************************************************
Has anybody noticed? Common Sents is Really NOT that Common.
THERE IS NO STOP SIGNS ON A MERGE LANE!!!
*****************************************************
07 Silverado 2500HD CCSB DMax (Daily Driver)
05 Volvo V70R (Totaled by an Impaired Driver)
57 Chevy Panel Van (project)
57 Mack B61 (for sale)
87 Chevy Kodiak Tilt N Load (SOLD Aug 03/10)
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   June 22nd 2012, 11:53 am

Second that, I really like the look without the tipper too lol. How about an update On the tires? Inquiring minds want to know.
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   June 22nd 2012, 9:40 pm

In2Trux wrote:
Awesome pictures.
Any body damage when you got stuck ???
I REALLY like the look with the topper gone

If you look really close at the last picture, just under the rear drivers side door, you will see that the rocker looks bent up a little bit. That's all I got. I like it with the topper off too, but it'll be going back on sooner rather than later. My dads truck is broken down in front of the space I have to get to to put it on, so it may be later, lol.

bigcountry78 wrote:
Second that, I really like the look without the tipper too lol. How about an update On the tires? Inquiring minds want to know.

Tires are great! 7,000 miles and they still have a ton of tread left, but I am getting some uneven wear out of the front thanks to my leveling kit. I rotated them at about 3,000 miles, so they are due again, I just haven't had the time to get it done yet since I am too darn lazy to do it myself.

I will try to update more often. Next thing is to get it refinanced so I can go buy a house! Plan on getting a little more than what I owe so I can also build a rear bumper with a spare tire carrier Wink (hence why the topper will go back on, since I think it'll look goofy without it).
Back to top Go down
007jimmy
Moderator
Moderator
avatar

Posts : 1955

Age : 33
Location : levittown, PA

PostSubject: Re: Long time and no picture post!   June 23rd 2012, 1:38 am

did you get it aligned after the leveling kit? i had to have my upper control arm mounts pulled out some on a frame machine when i lifted mine. Josh will tell you.. IT WAS BAD... lol my jimmy looked like one of these little hondas only stanced and tuckin 31s... lol
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   June 23rd 2012, 3:30 pm

007jimmy wrote:
did you get it aligned after the leveling kit? i had to have my upper control arm mounts pulled out some on a frame machine when i lifted mine. Josh will tell you.. IT WAS BAD... lol my jimmy looked like one of these little hondas only stanced and tuckin 31s... lol

Yes, it was aligned. What happens is that the leveling kit brings the weight of the truck off of the stops, putting it all on the ball joints. My ball joints went out in 7,000 miles.
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   September 26th 2012, 12:48 pm

Any more updates? Anything new? I'm still interested in the tires. I'm torn between those coopers and the firestone destination AT's.
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   September 26th 2012, 8:02 pm

My weird tread wear has disappeared after lowering the front down, and the tires are still impressing me. My ONLY complaint with them (and it could be because I don't have a limited slip rear more than anything) is that on a steep incline after a heavy rain they lose traction (in 2WD). Once I pull back the happy stick, it climbs great, though!

I haven't done much to the truck this summer mostly because of work. From my last post to labor day, I was working 5-6 days a week, 10-15 hour days, so needless to say my truck budget has been great! Ended up fixing the Ranger and have been driving it every now and then, though I think I will be doing a 5 speed swap in it soon.

For the Chevy, I have gathered up some parts for a project:



The swing out will be on the outside of the tail gate mounted to a custom made rear bumper. Still need to get the steel for that, but I have the plans drawn up and most of that swing out cleaned up and ready to go.

I took the topper off again and have been running it like this for a couple of weeks now:




I don't like how the rear sits up so much higher, so I am thinking I may invest in some heavy duty ball joints so I can raise the front end again. I do like that it has the same front height as a 3/4 ton on 33's though!

Moved my CB:



I had a sleeping platform built in the bed prior to removing the topper, but the design doesn't work for two people and two dogs, so I am changing it. Here it was finished, though!:



And one of the rare Saturdays I had off, we took the Bayliner and the 'yaks out to one of the smaller lakes and had a blast!:



Other than the rear bumper, my only other plans will be to get some power options installed (windows/locks) and some leather seat covers off of eBay. There is still a TON I want to do to the truck before I call it finished, but I need to put a little more money into the Ranger to make it a reliable DD. I do have a Subaru now too, but I have yet to drive it (got it in early July, LOL!)
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   September 29th 2012, 3:45 am

I'm still liking the no topper look. That tire carrier is goin to be sweet when you get it all done! I'm still liking that brushguard and lights. I had one on my 98 like that but I hated washing the truck with it on there. That's a pretty cool sleeping platform too, but my wife is way to claustrophobic to sleep under a topper lol. Glad to hear the tires are workin out for you. How many miles do you have on them? I'm askin because in lookin for a LT 265/70/17 in a load range C, and those tires are like one of three choices I have in the world apparently lol.
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   September 29th 2012, 9:35 am

I've got somewhere between 15-20,000 miles. It's actually time to rotate them Wink

I'm liking the no-topper look myself, but like I said, it'll be back on at some point. I took the brush guard off the night before last and I kinda like the look without it too. Makes it a lot easier to clean stuff, lol.

Got a bonus at work this week, so next weekend I think I will get some stuff done on the truck. Heading out to go hunting today and have a side job tomorrow. I will post pics after todays adventure!
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   September 29th 2012, 11:54 am

Sweet more pics!! Haha. Yea I ended up takin my brushguard off too, like you said it's easier yo clean the front end. You mentioned makin the ranger a DD, are you plannin on chopping up the Chevy for trail work?
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   September 29th 2012, 11:39 pm

Not so much chopping it as just making it the dedicated "recreational" rig. I want it to be set up to just get in and go camping wherever I want and not have to load or attach anything to do it. If I keep DDing it, it'll end up being that.

I actually do plan on chopping up the Ranger and making it a dedicated trail rig, but I need to actually blow the transmission up so I can use that as an excuse to tear it apart more. Like I said, I got a Subaru for a DD, I just need to get it put into my name so I can drive it. I have time after work now, I just keep forgetting.

Anyway, here are some pics from today.

Hanging out in town for a few while my buddy was taking a shower and getting ready to go:


First stop after 130 or so miles: Yaak River Falls:







The right one was what we were hoping to find (and we did, but Justin didn't want to get it):


And Justin in his Camo for a day of road hunting....always gotta look the part, even if it's nothing special, lol!


Up the road a ways, we found a lone USA flag with literally no other form of human habitation within a 20 mile radius:


A couple pics of the view at 5996 feet:



And the last one of the truck after a potty break at about 4700 feet:


I was hoping we would get a picture of an animal in the back, but we weren't too lucky today. I missed two grouse, and my buddy was too afraid to get a bear we saw cross the road (at least that is what I am telling everybody, him being afraid I mean), and the salmon fishing wasn't as good as last weekend was.
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   October 7th 2012, 12:03 am

Well, I finally broke down and bought a new head unit. I loved my old one and will be putting it in either the Ranger or the Subaru, but I haven't decided which yet. The new one is a Pioneer PAVH1400DVD. It plays DVD's, has navigation capabilities (a $400 part to add that, and since I have a GPS I am considering not doing that), can play Pandora if you hook your phone to it, and has a bunch of other features I haven't tried yet. I also ended up putting the topper back on, but I didn't get any pictures yet. Payday next Thursday, so I think I may get a new grille and pull the trigger on getting my power options installed, or window tint (can't do both at the same time). In January, I plan on getting some cross bars for the cab and a basket, and I will hopefully have the bumper built by then too.

Anyway, here is a picture of the head unit installed and playing everybody's favorite artist:



BTW, if you are looking at the pic, you just got rick roll'd Wink
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   February 4th 2013, 4:34 pm

Hey nice pics jimmeh! Quick question, is your brushguard listed on the Wilkes NC Craigslist? There's a black one on there identical to yours, same lights and everything. I've been lookin at it pretty hard lol.
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   February 4th 2013, 5:51 pm

Nope, mine is still on the truck. Still in Montana too, lol.
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   February 9th 2013, 6:03 pm

Ha my mistake. How's life treating ya?
Back to top Go down
Jimmeh
Valued Member
Valued Member
avatar

Posts : 136


PostSubject: Re: Long time and no picture post!   February 9th 2013, 10:02 pm

Life is good! Sorry I'm not active, though. Work, the little lady, new place and having fun has taken up a lot of my time lately.
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   February 13th 2013, 1:10 pm

Yea tell me about it lol. I've got my atv down right now, and I finally got my 78 back, promptly took it muddin and now it won't crank lol.
Back to top Go down
007jimmy
Moderator
Moderator
avatar

Posts : 1955

Age : 33
Location : levittown, PA

PostSubject: Re: Long time and no picture post!   November 25th 2014, 12:30 pm

Is this forum still alive
Back to top Go down
bigcountry78
Valued Member
Valued Member
avatar

Posts : 375

Age : 30
Location : N.C.

PostSubject: Re: Long time and no picture post!   April 17th 2015, 4:11 am

Still breathing I think...
Back to top Go down
Sponsored content




PostSubject: Re: Long time and no picture post!   

Back to top Go down
 
Long time and no picture post!
View previous topic View next topic Back to top 
Page 2 of 2Go to page : Previous  1, 2
 Similar topics
-
» New member, long time viewer. I'm heading to the golden triangle in Vic early Jan, any suggestions for areas?
» Lights stay on for a long time after car is off
» POST: pics of your XRR w/ various gas tanks and t
» Pulling the 944 engine (methods)
» It has been a long time but,

Permissions in this forum:You cannot reply to topics in this forum
Your Truck Source :: Off-Topic :: Pride and Joy-
Jump to: